Jeep Commander Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter #1
In the month or two i've had my commander, this has only happened twice. But i'm wondering if it is normal or I need to have something looked at. When i try to start the jeep, it doesn't crank as soon as i turn the key like it normally does, so i let go of the key. But even though i let go of the key, the starter continues to try to crank and eventually does. Maybe 2 seconds after i've let off the key. Does this happen to anyone else?
 

·
Registered
Joined
·
14 Posts
What year is your Commander? Could have a worn out starter. Have you checked all of your connections between the battery and the starter? Any corrosion? That would be first step I would take.
 

·
Registered
Joined
·
554 Posts
my guess would be the connection at the starter motor, corrosion
 

·
Premium Member
Joined
·
6,309 Posts
In the month or two i've had my commander, this has only happened twice. But i'm wondering if it is normal or I need to have something looked at. When i try to start the jeep, it doesn't crank as soon as i turn the key like it normally does, so i let go of the key. But even though i let go of the key, the starter continues to try to crank and eventually does. Maybe 2 seconds after i've let off the key. Does this happen to anyone else?
I've had this same problem. It doesnt happen often at all and I don't believe it's done it in the past year or so. It's something to do with the ignition, not the starter believe it or not
 

·
Premium Member
Joined
·
6,309 Posts
I have an 07 4.7 liter
 

·
Registered
Joined
·
210 Posts
I know my fathers 08, with the 3.7 will crank for you, until the engine actually starts. If you just bump the start position in the ignition, it will continue to crank until the engine starts, for 4-5 seconds i believe. Most new cars do this as well. In my 06 5.7 i need to hold the key until it starts, like older vehicles. Im thinking your 07 might have the smart start, like the newer vehicles. The no crank issue might be the typical commander faulty starter, Many horror stories on here about that. Mine ended up needing the starter harness from the batter, as well as a new starter.
 
1 - 8 of 8 Posts
Top