Jeep Commander Forum banner
1 - 3 of 3 Posts

·
Registered
2009 Jeep Commander limited with 5.7 HEMI 2" OME lift. CAI and some other odds and ends.
Joined
·
24 Posts
Discussion Starter · #1 ·
Well for a 2009 I'm not really surprised that this happened. I had jacked up the front end of my Commander the other day and noticed the inner tie rod boot was loose at the rack side and there was some fluid leaking from there. I was prepping the fender wells for bigger tires and didn't think much of it, I checked the PS fluid level and it was full. No less than 24 hrs later I was pulling into work and the steering didn't want to turn at slow speeds and I could hear the pump whining. Looks like I need a new rack. Oh and don't get me started on looking for PS fluid for these things I was researching for hours on here trying to figure it out. I'm hopping the pump isn't already damaged at this point.
 

·
Registered
2009 Jeep Commander limited with 5.7 HEMI 2" OME lift. CAI and some other odds and ends.
Joined
·
24 Posts
Discussion Starter · #2 ·
Well this is turning into a nightmare, the rack I received from rockauto doesn't fit. The shaft is the wrong shape for my steering shaft and doesn't fit. Also the rack appears to be too shorter on one side than my stock rack. Now rockauto is refusing to refund me because the rack was installed. How else would I have known it was wrong?
 

·
Registered
2009 Jeep Commander limited with 5.7 HEMI 2" OME lift. CAI and some other odds and ends.
Joined
·
24 Posts
Discussion Starter · #3 ·
well for those of you following this thread, i had to buy the OEM rack through rockauto, it had a five day delay and was over 800 dollars. well its finally in and now the dash is lit up like a Christmas tree. ESP, BAS, Airbag and no steering wheel controls. I guess a clock spring is next.
 
1 - 3 of 3 Posts
Top