Jeep Commander Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
143 Posts
Discussion Starter #1
Noticed some extra noise coming from the sunroof and jumped out to see it's not fully lifting when it closes. The tilt feature and slide feature both works fine, but it wont lift all the way when it comes to a stop after closing the slide. I had the battery replaced last weekend and didn't drive it until this past weekend and noticed this for the first time.

Other than that? No idea why it doesn't fully close. Anyone have this issue?
 

·
Super Moderator
Joined
·
14,939 Posts
I don't know if this will help, but it is worth a try.

Place the ignition switch in RUN position.

Close all of the doors.

Press and release the vent switch (sunroof should move to vent position).
Once the sunroof has stopped motion at the vent position, press and hold the vent switch
for at least 5 seconds to recalibrate the sunroof position.

If the sunroof did not reach the full vent open position, press and hold the vent switch until
the full-vent-open position is reached then release the vent switch, then press and hold the
vent switch for at least 5 seconds to recalibrate the sunroof position.

Cycle the sunroof from the full-vent-open position to the full-slide-open position and back to
the full-vent-open position at least 7 complete times. The sunroof is now in customer mode
with the obstacle detection thresholds updated.

 

·
Registered
Joined
·
371 Posts
I had the same problem and followed this procedure. When I did, the two metal arms snapped off.
 
1 - 5 of 5 Posts
Top