Jeep Commander Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have a 2006 commander limited with the hemi and a factory installed trailer harness. The RV plug has power to grownd but no functions get power. I've checked relays and fuses and can only come up with a possible bad module under the driver's rear quarter panel. Does anyone have any experience with something like this??? Thanks for any help.
-John
 

·
Premium Member
2006 Commander Limited, 5.7 Hemi QD2
Joined
·
824 Posts
When you say it has power to ground - what pin are you referring to? Below is a picture of the connector. And what do all the other pins read (from ground)?

42333
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
I have the 7 blade RV plug but I believe this diagram is identical. The "battery" pin reads power to ground. All other pins do not read any power to ground while I have the function working on the vehicle( flashers on, running lights on, brakes pressed). I hope it's the module that needs replaced although my local dealer can't seem to find the part number for it to even order haha.
 

·
Premium Member
2006 Commander Limited, 5.7 Hemi QD2
Joined
·
824 Posts
Well now you have me thinking. Found in the service manual the the "Front Control Module may be where to check first.

42334
 

·
Premium Member
2006 Commander Limited, 5.7 Hemi QD2
Joined
·
824 Posts
Also did the trailer lights ever work right? Do you know if any parts were replaced. especially the front control module? There are different ones and maybe some do not have trailer function. Also the dealer has to program trailer functions if added on or changed?
 
  • Like
Reactions: Spyder

·
Registered
Joined
·
240 Posts
Assuming you checked the connector behind/above the hitch, in the spare tire well? It couldve come loose, or been damaged.
Also tucked up in there is a flat 4 connector you can probe too and verify the RV plug itself isnt the problem.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
I was checking for power before and after the rear module which is before the RV plug. Pretty much everywhere there was a wire for the trailer plug in the back. I will look into the front module as I haven't heard of it until now thanks for all the advice and research
 
1 - 7 of 7 Posts
Top