Jeep Commander Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hello all,

Our 2007 Commander started throwing code P0734 (Gear 4 Incorrect Ratio; http://www.obd-codes.com/p0734 if you care to read more about it) about two weeks ago. Seems to only do it when my wife drives it but she's a little more led footed than myself. It doesn't feel like the trans is slipping but there is a jerking motion and a little bang when the issue occurs. It reminds me of my Cherokee when the U joints went bad on the drive shaft.

The Jeep is due for a trans fluid/filter change so I figured I'd do that first in hopes this would fix the problem. It unfortunately hasn't. One thing I did notice while I had the pan dropped and both filters out is that there are a ton of small cracks inside the transmission. I've attached some pictures for reference.

Has anyone ever seen anything like this before? I've done my share of trans fluid changes on other vehicles and have never seen the inside of a transmission look like this.

Any insight on the P0734 code would also be helpful. I'm afraid this thing might be failing and is going to require a rebuild :grim:
 

Attachments

·
Registered
Joined
·
309 Posts
I had this code a couple years ago.

Couple quick questions:
Do you have stock tires and wheels?
Is your TCM, ECU, and FCM up to date?

I had over size tires and that threw the code, updated with my diablo tuner and it went away...
Last year my overdrive completely ate itself inside the case. Turns out, the Trannys (45RFE) have defects. Fiat/ Chrysler paid to replace my transmission. Go to a transmission shop in your area and get it inspected before anything bad. I will look for the FCA link I went to to report my Transmission issue.
You have to pay for the work first, but I got 100% reimbursed and an additional warranty :)
FCA took care of my truck and I have heard of many others who had very good results with this.

Dave
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
I had this code a couple years ago.

Couple quick questions:
Do you have stock tires and wheels?
Is your TCM, ECU, and FCM up to date?

I had over size tires and that threw the code, updated with my diablo tuner and it went away...
Last year my overdrive completely ate itself inside the case. Turns out, the Trannys (45RFE) have defects. Fiat/ Chrysler paid to replace my transmission. Go to a transmission shop in your area and get it inspected before anything bad. I will look for the FCA link I went to to report my Transmission issue.
You have to pay for the work first, but I got 100% reimbursed and an additional warranty :)
FCA took care of my truck and I have heard of many others who had very good results with this.

Dave
thanks for the info, dave. i'm running stock sized tires. i have heard of the tranny having defects but found nothing definitive when i quickly googled it. i'll have to look into it more. so far, as long as we baby it, it doesn't jerk while driving and also hasn't thrown the code again. i can't imagine this "fix" working forever though.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
I had this code a couple years ago.

Couple quick questions:
Do you have stock tires and wheels?
Is your TCM, ECU, and FCM up to date?

I had over size tires and that threw the code, updated with my diablo tuner and it went away...
Last year my overdrive completely ate itself inside the case. Turns out, the Trannys (45RFE) have defects. Fiat/ Chrysler paid to replace my transmission. Go to a transmission shop in your area and get it inspected before anything bad. I will look for the FCA link I went to to report my Transmission issue.
You have to pay for the work first, but I got 100% reimbursed and an additional warranty :)
FCA took care of my truck and I have heard of many others who had very good results with this.

Dave
and as far as everything being up to date, how would one know? i take it to the dealer for oil changes usually but i'm not certain this is something they would just do. all the recalls have been taken care of.
 

·
Registered
Joined
·
309 Posts

·
Super Moderator
Joined
·
14,912 Posts

·
Registered
Joined
·
1,480 Posts
Do all our XK's have the the (45RFE) transmissions ? The dealer was guessing between a drive shaft and torque converter onmy 06 xk. We went with the drive shaft on their nickel and it fixed the problem, but I suspect more problems in the future, and yes I am way out of waranty.
 

·
Registered
Joined
·
309 Posts
I am the second owner and at 107K miles. I am really out of Warranty, all that was required was a copy of the invoice from the shop that did the work.

I attached the receipt I used to make the warranty claim. I mentioned the N23 recall, I did it just for giggles...

Dave

Dave, how many miles were on your Commander ? It was out of warranty, right ? And they paid for it ?
 

Attachments

·
Premium Member
Joined
·
224 Posts
thanks for the info, dave. i'm running stock sized tires. i have heard of the tranny having defects but found nothing definitive when i quickly googled it. i'll have to look into it more. so far, as long as we baby it, it doesn't jerk while driving and also hasn't thrown the code again. i can't imagine this "fix" working forever though.
Whatever happened with your Tranny?
 
1 - 10 of 10 Posts
Top