Jeep Commander Forum banner

461 - 480 of 538 Posts

·
Administrator
Joined
·
15,246 Posts

·
Registered
Joined
·
134 Posts
Here is a link to my post about this key Fob and what you need to know.
Also here is the Ebay link to where I purchased this. Important, you need TWO working key FOBs in order to program this one
 

·
Registered
Joined
·
134 Posts
So today I attempted to tackle my tail light running problem after getting off work. Had some day light left and felt I could knock it out seeing that I had a wire harness already and wanted to test if that would fix the issue. It did not and looking closer to the harness I order it had corrosion on on of the sockets so I contacted the ebay seller for a refund. On a whim I decided to swap the left tail light with the right seeing that one does work and it wouldn't light up correctly either. So it's not a wire harness issue. Back to the chalk board
 

·
Registered
Joined
·
134 Posts
Update. So popped the hood and tested the ICM (Integrated Power Module) and they seemed to be fine so I had a spare relay and swapped out the parking lamp relay R7 and BINGO! That was the culprit. Still though I did need a tail light regardless becuase of that crack. Also another pleasant surprise I found. In a previous post I made where I had blown out all the back light for the AC, Information bar and Shifter illumination they are working again. From all the tracking I did through the diagram I didn't see that they were connected to that particular relay, but as they say "Never look a gift horse in the mouth"
 

·
Administrator
Joined
·
6,288 Posts
Update. So popped the hood and tested the ICM (Integrated Power Module) and they seemed to be fine so I had a spare relay and swapped out the parking lamp relay R7 and BINGO! That was the culprit. Still though I did need a tail light regardless becuase of that crack. Also another pleasant surprise I found. In a previous post I made where I had blown out all the back light for the AC, Information bar and Shifter illumination they are working again. From all the tracking I did through the diagram I didn't see that they were connected to that particular relay, but as they say "Never look a gift horse in the mouth"
That's good news @RoninSpectre; Glad you got it all sorted out.

If you can, take a pic of the relay that you replaced.
 

·
Registered
Joined
·
134 Posts
So replace my headlight about half an hour ago and fit perfectly. While I'm at it I also order an instrument cluster from Ebay. My plans are once it arrives I will remove the ERPOM chip from my original and replace it with the one I ordered in order to maintain the mileage exact. I did happen to find an instrument cluster that had matching part number thankfully, but I'm not entirely sure how much that would matter if I do swap out the EPROM chip. I'll keep you up to date once it arrives.
 

·
Registered
Joined
·
134 Posts
So my newish Intrument cluster arrived today and took it apart in order to swap out the EPROM chip so that I could maintain the exact miliage oh and the reason for this all was a faulty Egnine Temp Gauge by the way. So once inside I discovered the EPROM chips to be far smaller than anticipated. Couple shots of it


41204
41205

As you can see the chip at it's widest is the length of a grain of rice. So with something that small I didn't feel too confident in my soldering skills with such small pieces. So with that in mind I'm currently just going to remove the mechanism for the Engine Temp Gauge instead. Will update later.
 

Attachments

·
Administrator
Joined
·
6,288 Posts
So my newish Intrument cluster arrived today and took it apart in order to swap out the EPROM chip so that I could maintain the exact miliage oh and the reason for this all was a faulty Egnine Temp Gauge by the way. So once inside I discovered the EPROM chips to be far smaller than anticipated. Couple shots of it


View attachment 41204 View attachment 41205
As you can see the chip at it's widest is the length of a grain of rice. So with something that small I didn't feel too confident in my soldering skills with such small pieces. So with that in mind I'm currently just going to remove the mechanism for the Engine Temp Gauge instead. Will update later.
That's definitely a very delicate soldering job, I'd be hesitant to try that myself - and I'm pretty good with a soldering iron.
 

·
Registered
Joined
·
134 Posts
Back from that soldering job I'm happy to say that the issue is fixed. Replacing the small motor gauge is a far easier job that trying to replacing that EPROM chip.
41211

Pic shows after I had removed the solder
 

·
Administrator
Joined
·
6,288 Posts
Back from that soldering job I'm happy to say that the issue is fixed. Replacing the small motor gauge is a far easier job that trying to replacing that EPROM chip.
That's good to hear, you have any pics of the small motor gauge?
 

·
Registered
Joined
·
134 Posts
That's good to hear, you have any pics of the small motor gauge?
Edited my previous post an added a pic of the 4 solder point where it's attached to the board. It's pretty easy to do, but I do suggest if you don't have a reverse suction syringe to draw out the molten solder then get one. Makes this job a lot easier
 

·
Registered
Joined
·
134 Posts
So finally got some free time I went to a local muffler shop to get my catalytic converters replaced having had a check engine light for a failing bank 2 converter. Originally I was thinking to replace the entire assembly, but after speaking to the shop they could just cut out both and install new ones for a fraction of the cost of the whole it just made more sense for me who is on a budget. Here are some pics.
41230
41234
41233
41231
41232
 

·
Administrator
Joined
·
15,246 Posts

·
Registered
Joined
·
134 Posts
That's good to know and it definitely makes sense to go that route;

I'm guessing this cleared your check engine light??
The gentlemen cleared the code before replacing them, so at the moment no code, but I will keep and eye on it. The strange thing is that this code would come and go so my suspicion is that the bank 2 converter was borderline failing.
 
461 - 480 of 538 Posts
Top