Jeep Commander Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
4WD 3.7L
The noise starts at about 55mph and is worse under bigger loads. in neutral and coasting, no noise. Vehicle has 145,000 miles. My guess is the front differential/driveline but I'm not sure where to even begin looking for issues. Thanks!
 

·
Premium Member
Joined
·
6,309 Posts
Is it a whining or howling noise? Maybe a wheel bearing. Does it get louder when your at at speed and turn the steering wheel left and right?
 

·
Registered
Joined
·
104 Posts
You say the noise is silent when in neutral or coasting.

Are you putting it in neutral and coasting at 55+?

If so, what is the 4WD setup you have? Command Trac, Quadra Trac, Quadra Drive?

Is there any noticeable loss of power?

We need TONS more info.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
I changed the front diff oil with royal purple 75-W140. No metal shards, just dirty oil. And yes I did put it in neutral at 55+ mph and no noise. And now that you mention it, it is more of a howling noise. I just drove it on a long trip and it makes the noise from 55 to 65 mph. No matter where the RPM is at it's making the noise at that speed. 70 to 80 mph, it runs like new (especially after the front diff oil change). Transmission? Transfer Case? I like to be my own mechanic so unless its the tranny I can fix it. Thanks guys!
 

·
Registered
Joined
·
571 Posts
The first code thrown is the one needing addressed. The second code is probably a result of the first. The TCM is an expensive module that when replaced, needs to be flashed, or programmed... i'd call around and find a local shop that can do the repair AND have it flashed...although you may be stuck going to a dealership. Theres a thread in here, with pics, on how to remove the shifter assembly and cleaning the contacts.
 

·
Registered
Joined
·
2 Posts
I have the exact same problem under acceleration, 2007 jeep commander 5.7
Between 58 and 65 miles an hour, it sounds like it’s coming from under the hood by the driver front wheel. Only makes the whining noise when accelerating not when I let off the gas.
 

·
Registered
Joined
·
2 Posts
4WD 3.7L
The noise starts at about 55mph and is worse under bigger loads. in neutral and coasting, no noise. Vehicle has 145,000 miles. My guess is the front differential/driveline but I'm not sure where to even begin looking for issues. Thanks!
Allen, I have exact sammme issue, no codes yet. Still drives fine but a nuisance. Were you able to get yours fixed, and if so how much did it cost? And what was the final diagnosis? Thanks for any insight you can provide sincerely Chris
 

·
Administrator
Joined
·
7,306 Posts
Allen, I have exact sammme issue, no codes yet. Still drives fine but a nuisance. Were you able to get yours fixed, and if so how much did it cost? And what was the final diagnosis? Thanks for any insight you can provide sincerely Chris
Chris;

That member has not been on the forum in over 7 years.

Also, please complete your user profile signature as directed;

Important New Member information, Forum requirements & Forum rules. | Jeep Commander Forum

Thank you.
 
1 - 10 of 10 Posts
Top