Jeep Commander Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Crazy as it sounds, I put a lift/level kit on my Commander and now the windows wont' work. The circuit contains the courtesy lights and glove box light which all work but I checked the fuse anyway - no issue. Power mirror switch is in the same module as the window switch and it works. I tried the posted reset procedures but nothing. Any ideas?
 

·
Administrator
Joined
·
16,134 Posts
@Hexman I doubt that the lift had anything to do with the windows not working. Is it just one window or all of them?

.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
@Hexman I doubt that the lift had anything to do with the windows not working. Is it just one window or all of them?

.
I agree completely however part of the installation process requires removal of the under hood fuse boxes. Doesn't seem likely that would be it but it's all 4 windows.
 

·
Registered
2008 Jeep Commander Sport 4.7L V8
Joined
·
264 Posts
Check the driver side door wires inside the rubber loom. If the wires are stretched and coming apart that would cause it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Check the driver side door wires inside the rubber loom. If the wires are stretched and coming apart that would cause it.
Thanks, I plan to check that this weekend but none of the windows work and none of the window switches work.....
 

·
Registered
2008 Jeep Commander Sport 4.7L V8
Joined
·
264 Posts
Sounds like a wire in the door, same thing happened to me. I think it's because the driver door has all the controls .
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Don't know how much this would help others installing a lift/level kit but you'll need to temporarily move the under hood fuse boxes and this is causing me to have some funky electrical problems after reassembling. Probably unavoidable with a 13 year old Commander. I guess just be careful when moving things and putting them back together.
 

·
Registered
Joined
·
1 Posts
Crazy as it sounds, I put a lift/level kit on my Commander and now the windows wont' work. The circuit contains the courtesy lights and glove box light which all work but I checked the fuse anyway - no issue. Power mirror switch is in the same module as the window switch and it works. I tried the posted reset procedures but nothing. Any ideas?
Just finished fixxing the same issue on mine.

1st. First start with checking your fuses. Theres a body/ interiour fuse panel that contains a dome light fuse. And its located behind above the brake pedal on your left side. From what you've described it sounds like that fuse has blown. ( No front window controls, no mirror controls, no dome light/ courtesy lamp) : is what i was experiencing.

2nd.If no blown fuse is found check the wiring inside the boot from cab to driver door ( a lot of the time wires will get brittle and break after opening and closing the door many times).

Short of that, you may have a Driver Door Module that has gone bad.

Hope this helps.
 
1 - 8 of 8 Posts
Top