Jeep Commander Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter #1 (Edited)
Hey all, thought I'd give a warning about these lugnuts. Had them on about 8 months or so. I got to do a rear brake job, and on one wheel, had three of these break off right where the spline ends and the acorn starts. All three had rusted through all the way to the center. I removed all of them from my vehicle and they all had rust lines in the same spot where the others broke at.
It took a tire shop 2.5 hours to torch them off, ruining the chrome clad rim, got wacked $135, for that and still got to find a new rim.

 

Attachments

·
Premium Member
Joined
·
2,337 Posts
Good to know, thanks for the head's up. Might swap back to regular lug nuts so I don't have to worry about the special wrench and this issue. Probably all the winter salt in your area ate right through them.
 

·
Registered
Joined
·
696 Posts
what manufacturer? Mine looks similar to those but are not black. I know for sure they are Pro Comp and Pro Comp I thought was good stuff
 

·
Registered
Joined
·
97 Posts
Discussion Starter #5
I dont remember the brand but mine were chrome. If you look at the pic y9ou can see the rust line on the one that isn't broke. All 22 other lugs had the rust line around them.
 

·
Registered
Joined
·
97 Posts
Discussion Starter #7
Never used an impact, just a 4way.
 

·
Registered
Joined
·
97 Posts
Discussion Starter #9
Thats why I'm giving ya'll the warning. Sure the wintery conditions, and salt may have contributed to it, but to last last then a year. I know I wont be using them again.
 
1 - 9 of 9 Posts
Top