Jeep Commander Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
541 Posts
Discussion Starter · #1 ·
I took my Commander to the dealership with the windshield problem for the second time. First time they resealed it, but I still have some noise on the passanger's side. They said they couldn't do anything since they couldn't replicate the problem. I called Jeep, and they said all I could do is take it to another dealership. I will do so, like if it was the first time it is serviced for that. I was fuming. They said they drove my vehicle at 80MPH and couldn't replicate the problem. First of all, what the hell are they doing driving my vehicle at those speeds? Then they sell me the rear assist chrome handles. They then give me only the handles, not the covers, screws, etc. Trust me, I've had better days.
 

·
Registered
Joined
·
24 Posts
I feel the pain Dabitz, I've had some issues with my local dealership too. Mainly really poor customer service issues, you know not the old above and beyond. It's like I'm wasting their time, HELLO.... isn't this your job!!

Hang in there. However, it's nice to have such a community to vent to. Am I right!
 

·
Registered
Joined
·
541 Posts
Discussion Starter · #3 ·
My frustration is I read so many posts of people that get the windshield replaced, so why is mine such a big issue? I will take it to another dealership to see what happens... regarding the handles, it was my fault. As these are not accessories, but parts, everything is sold for separate. At least they gave me employee pricing on the remaining parts.
 

·
Registered
Joined
·
476 Posts
drop_d said:
Mainly really poor customer service issues, you know not the old above and beyond. It's like I'm wasting their time, HELLO.... isn't this your job!!
I agree..where the hell is the customer service within the DCX dealerships? Also, they evidently must all attend the same class and must have to write "we could not duplicate" about 1000 times so it becomes ingrained in their little minds :eek: as this seems to be the standard answer for everything.

Here is what I did to solve that problem: I have had an ongoing issue where the passanger side window auto-up will reverse and go back down and an issue of water in the passenger floor AND a terrible squeel from the rear break - ALL of which I was told "we cannot duplicate":rolleyes: Here is what I did:
--> Window - useing my digital camera in video mode...took video of the window auto-reversing
--> Water in floor - too digital photos of the wet carpet and underside of the floor mats
--> Squeel from rear... used a digital recorder to record the sound when coming to a stop.

I then e-mailed these to the persident of the dealership and the service manager... amazing... they were able to correct the issues. - ALTHOUGH - they still have not got the leak fixed (in for the 2nd time as of today).
 

·
Registered
Joined
·
213 Posts
my advice would be to try and find a "5-star" dealer - they generally seem more interested in making you (the customer) happy so you can give them a good review on the surveys, and they can keep their 5-star status...
 

·
Registered
Joined
·
476 Posts
Strange... I seem to no longer get the survey :confused:

As often as my XK is in for repair I guess they have figured out a way to not have these sent to me!

Will contact DCX and inquire.
 

·
Premium Member
Joined
·
229 Posts
When I got the ol' "unable to duplicate" routine I just marched on over to the Service Manager's office, tossed him my keys and said "c'mon, let's take a short drive", hard to deny the obvious when you're in their face.

Good luck with the next dealership, I know it's not easy, but try to be positive and leave the negativity of this experience behind when you walk through their doors.
 

·
Registered
Joined
·
541 Posts
Discussion Starter · #9 ·
I drove my vehicle myself at 80MPH and couldnt' duplicate the problem again. The day it happened it was hot and very windy. I am off to the NJ Turnpike this weekend and will try to get it on DVD.
 

·
Registered
Joined
·
541 Posts
Discussion Starter · #10 ·
Spoke to the service manager the at dealership as he called and said that he would like to take a ride with me to find out where the noise is coming from. Today it is hot in NJ, and the truck is doing the noise like crazy... but now he says he can't do this until Monday as he is trying to close the week. (had another dealership appt on Monday). I bet you it is going to be cold and rainy on Monday... Ahhhh :mad:
 

·
Registered
Joined
·
110 Posts
I've been very fortunate not to have any windnoise issues w/ my XK. I do know that my dealership doesn't fiddle around w/ the windshield issues because they have an on site glass shop and it is far easier for them to re-install and seal the windshield by hand.

This dealership provides me w/ a new loaner vehicle even if I'm only in for an oil change. When I had my XK in for service they gave me a new 65th Anniversary XK and because I was from out of town they let me keep it overnight. This vehicle was quiet as mine in the cool late evening and early morning hours but during the heat of the day sounded like Jethro Tull was on the roof playing a monotone/flat flute. It was so bad that thoughts of suicide entered my mind. When I noted this to the dealership they immediately recognized the problem telling me that it was the header trim strip above the windshield. When it gets hot it becomes very flexible and vibrates at highway speeds making the noise. Almost like blowing air across a blade of grass held between your hands. I have since driven the same 65th Anniversary on a hot day and it no longer makes this noise so I assume it was fixed.

XKPearl
 

·
Registered
Joined
·
204 Posts
XKPearl said:
When I noted this to the dealership they immediately recognized the problem telling me that it was the header trim strip above the windshield. When it gets hot it becomes very flexible and vibrates at highway speeds making the noise. Almost like blowing air across a blade of grass held between your hands. I have since driven the same 65th Anniversary on a hot day and it no longer makes this noise so I assume it was fixed.

XKPearl
DCX released an RRT for this a few months ago, all XKs in inventory should have been fixed. I know we did ours when we had time, if they didnt get fixed allready they were completed during the delivery prep. Pretty simple, they just wanted us to run a bead of clear silicone behind the strip, we had about 40 in inventory that had the repair done. DCX isnt the only one to ever have this issue either, I ran into a similar problem years ago while working for Kia. Drove me nuts, could hear it at highway speeds only and had a hard time locating it until it suddenly stopped. I pulled over to find the weatherstrip had come completely loose and was laying back on the roof, lol. Sometimes wind noise complaints can drive you nuts, especially if its an isolated case like that one was.
 

·
Registered
Joined
·
541 Posts
Discussion Starter · #13 ·
The original dealership which I had troubles with had indeed done the quick repair on the bulletin issued. I took it for a second time as the sound now was coming from a different area and that is when all the issues I described happened.

Well yesterday I tooked it to another dealership in Westwood NJ, they fixed the problem by sealing some lose molds that the original dealership didn't bother to look at since they couldn't replicate the problem. So far so good! They are even fixing the little door you open to reach behind the fog lights that I accidentally broke installing xenon lights.

I do still have a little rattle noise inside the glove compartment that they couldn't replicate. I will seek advise on that on a separate post.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top